云服务器知识

windows 服务器下php环境配置的一些细节

  

1.windows下php 版本选择非线程安全版本,提前安装VC9库

2.03下php5.3上版本需要安装fastcgi,不支持php5.5及以上版本,

3.php5.3,及5.4版本需修改php.ini 中的 时区为  Asia/Shanghai,

且在c:/windows/system32/inetsrv/fcgiext.ini末尾添加下面代码

[Types]
php=PHP
[PHP]
ExePath=C:php5.3php-cgi.exe
EnvironmentVars=PHP_FCGI_MAX_REQUESTS:10000,PHPRC:C:php5.3

4.08下的php版本控制,通过安装软件phpmanage来实现

5.禁用php危险函数     disable_functions 之后添加函数名

6.开启php错误显示     display_errors =On

7.可通过phpinfo函数查看php版本信息以及是否安装成功

8.IIS 7下asp启用父路径,开启32位程序池,否则可能影响php的使用

参考文档: 一些需要禁用的危险函数